GPTZero - AWS is down, leading to outage for a large portion of the internet's websites. – Incident details

AWS is down, leading to outage for a large portion of the internet's websites.

Resolved
Degraded performance
Started 3 days agoLasted about 3 hours

Affected

Cloud Infrastructure

Third Party: Amazon Web Services → AWS ecs-us-east-1

Third Party: Amazon Web Services → AWS ec2-us-east-1

Third Party: Amazon Web Services → AWS eks-us-east-1

Third Party: Amazon Web Services → AWS elb-us-east-1

Third Party: Amazon Web Services → AWS lambda-us-east-1

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating this incident.

    More information on how this outage is impacting websites like Snapchat, Amazon, Fortnite, etc: https://www.cnn.com/business/live-news/amazon-tech-outage-10-20-25-intl